Get in touch
Back
Degraded

Something went wrong while fetching your applications

Started 2 Feb at 10:46am GMT, resolved .

Portal
Resolved

This issue has now been resolved

Posted .
Created

Some users are receiving an error message stating "Something went wrong while fetching your applications" . If this occurs please use the direct links below to access our applications:
Aize : https://app.aize.io/
Information Exchange : https://ix.aize.io/
Project Execution : https://pec.aize.io/
Visual Construction Planning : https://vcp.aize.io/

Posted 2 Feb at 10:46am GMT.