Get in touch
Back
Resolved

Issue showing Tag in 3D from search for some customers

Started 24 Apr at 10:05am BST.

Aize
Created

We are aware of an issue impacting tag and 3D linkage. The customer has been informed and we are working to resolve the issue.

Posted 24 Apr at 10:05am BST.