Get in touch
Back
Resolved

Slow performance

Started 9 Jan at 11:18am GMT.

Aize
Created

We are experiencing a temporary issue due to our Cloud Provider in the region EastUS2 currently experiencing a network outage. We are in touch with them and are carefully monitoring for recovery. We apologize for the inconvenience this is causing.

Posted 9 Jan at 11:18am GMT.