Get in touch
Back
Resolved

Aize application not loading

Started 31 May at 05:20pm BST.

Aize
Created

We are aware that the Aize application is currently down and working to get it back up

Posted 31 May at 05:20pm BST.